Results 1 to 2 of 2

Thread: P0327 code keeps coming back

  1. #1
    Registered Newbie

    Join Date
    Feb 2018
    Posts
    1
    vCash
    500

    P0327 code keeps coming back

    Hello,

    I have a 2006 trailblazer ss I recently got a procharger installed and ever since the install I've been dealing with the knock sensor code P0327. I have replaced both knock sensors and the harness and the code keeps coming back. It only comes on when I give it 50% of throttle or more if I drive normally it doesn't come on. I don't hear any knocking can it be the tune? I'm gonna take it back to the shop. This has been such a headache.

    Mods:

    D1sc procharger @ 9 psi
    1 7/8 headers w/ high flow cats
    exhaust
    Stock fuel pump w/ kenne bell boost a pump
    Tr6 plugs

    Are the tr6 plugs too hot Maybe? My estimated power is 525awhp.

    Thanks!

  2. #2
    gettin' screwed...
    BigKID's Avatar

    Join Date
    Feb 2004
    Location
    PCB, Fl
    Posts
    6,835
    vCash
    490
    Knock sensors need to be installed at the 15 ft/lb torque spec or they will malfunction. I would also recommend sealing the rubber plugs with silicon to keep the holes from filling with water over time and corroding the sensors.
    I would also consult your tuner as it sounds plausible you could actually be getting knock whenever getting into boost due to a lean condition. The pcm/sensors hear it way before it is audible.
    The TR6 are the heat range I would recommend on that setup although I would suggest a non-projected tip plug such as the BR6EF and tighten the gap to 0.035.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •