Results 1 to 6 of 6

Thread: Blowing fuse for center stack lighting

  1. #1
    I choked Linda Lovelace RATFINK's Avatar

    Join Date
    Feb 2004
    Location
    Alabama
    Posts
    2,209
    vCash
    500

    Blowing fuse for center stack lighting

    The wifeys g8 is blowing the l4 fuse which is listed as INADV/PWR/LED which runs all the led indicators in the center console and I believe the trunk light and possibly a few other things...

    Just wondering if anyone else has had this problem and subsequently where I should look first.

    It doesn't blow the fuse just as soon as you snap it in, it takes it 4-5 seconds to blow and everything lights up fine until it pops.

    I'm going to try and isolate everything at the BCM tomorrow, but I figured maybe this was something someone else had already seen??

    Love the g8 though... and it keeps the wife out of my z06 so I can now mod it how I see fit.

  2. #2
    Marsupial
    HSV-GTS-300's Avatar

    Join Date
    Apr 2004
    Location
    Perth Australia
    Posts
    16,211
    vCash
    500
    Check the sunvisor wiring for pinch and chafe points.

    READ THIS PDF.
    #PIC4862A: Vanity Mirors Reading / Map Lamps Trunk
    Lamp And Heated Seat Switch LEDs Inoperative -
    http://www.grrrr8.net/crazypaul/PIC4862A.pdf

    Supporting Pics & Info.




  3. #3
    I choked Linda Lovelace RATFINK's Avatar

    Join Date
    Feb 2004
    Location
    Alabama
    Posts
    2,209
    vCash
    500
    That was in fact the problem.... thanks, you saved me a bunch of troubleshooting.

  4. #4
    Marsupial
    HSV-GTS-300's Avatar

    Join Date
    Apr 2004
    Location
    Perth Australia
    Posts
    16,211
    vCash
    500
    You're welcome, glad I could help.

  5. #5
    wigglewigglewigglewigglew iggleyeah

    Marklar's Avatar
    1 Highscore

    Join Date
    May 2004
    Location
    Fox Lake, IL
    Posts
    43,587
    vCash
    500
    Wow HSV..did you design the car or what?

    Who would EVER find that problem at the VISOR? Great info!


  6. #6
    Marsupial
    HSV-GTS-300's Avatar

    Join Date
    Apr 2004
    Location
    Perth Australia
    Posts
    16,211
    vCash
    500
    Quote Originally Posted by Marklar View Post
    Wow HSV..did you design the car or what?
    Who would EVER find that problem at the VISOR? Great info!
    All credit needs to go to RATFINK for the accurate and concise description of the problem. The first line alone was enough for anyone familiar with the car to know the answer.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •