Results 1 to 8 of 8

Thread: P0420 and P0430 codes

  1. #1
    Master Debater C4S's Avatar

    Join Date
    Feb 2004
    Posts
    2,222
    vCash
    500

    P0420 and P0430 codes

    Plugged in the programmer I got from Checker and I have two codes (my SES light is on which is why I got it).

    Codes are:

    P0420 Catalyst System Efficiency Below Threshold ( Bank 1)
    P0430 Catalyst System Efficiency Below Threshold ( Bank 2)

    From my understanding from browsing is it looks like it's either the 02 Sensors or a problem with the Cat itself.

    Question is, can I easily verify which one is causing the problem by myself and what can I do to fix if it's either one?

    Thanks!

    CS

  2. #2

    eboggs_jkvl's Avatar

    Join Date
    Feb 2004
    Location
    Jacksonville, Florida
    Posts
    97,046
    vCash
    2025
    Any mods to the car?
    2014 C7 Victory Red Convertible, 3LT, Z51

  3. #3
    On with life... Turbo? BlackDragon's Avatar

    Join Date
    Mar 2004
    Location
    Indianapolis, IN
    Posts
    396
    vCash
    500
    I have the P0430 code popping up and think that it's just a bad sensor. I can clear it out and of course, it comes right back. However, it is kind of odd when it comes back. I can drive to work and get the car and cats up to opperating temp and then stop at a light at idle and it will come on. Have heard someone mention a plugged cat that stays cool while moving but the cat doesn't get red when I can get under the car to look for myself. Ergo, my conclusion it's just a bad sensor. When I monitor the O2 sensor during stops and the SES light comes on, I've seen the O2 stop sending it's occilating signal to the PCM.

    For me, I'm not too worried since i'm gonna poke out the cats when I get my dual exhaust put on. I'm just gonna make up my own O2 sims and do away with them all together.

    BTW, i'm using a unique code scanning and monitoring software and OBDII interface to check all these things out.
    Last edited by BlackDragon; 05-19-2004 at 07:57 AM.
    God rest Ye soul:
    2000 Pontiac Trans Am - M6

    Rice anyone?

  4. #4
    Registered Member

    Join Date
    Feb 2004
    Posts
    1,958
    vCash
    500
    those codes fire off when you take the cats off.

  5. #5
    Master Debater C4S's Avatar

    Join Date
    Feb 2004
    Posts
    2,222
    vCash
    500
    Originally posted by eboggs_jkvl
    Any mods to the car?
    Just a cutout so far. I hope it's just the sensors but I'm suspicious that they both went out at once. I just want to know if this is something I can easily fix so I don't have to take it in to the dealer (which is something I'm going to look into doing today).

    CS

  6. #6

    eboggs_jkvl's Avatar

    Join Date
    Feb 2004
    Location
    Jacksonville, Florida
    Posts
    97,046
    vCash
    2025
    I just added P0420 & P0430 to the list. I missed them when I made the links in the Help thread.


    http://www.ls2.com/usa/showthread.ph...hreadid=178439


    E

  7. #7
    Registered Member King James's Avatar

    Join Date
    Mar 2004
    Location
    Indiana
    Posts
    7,679
    vCash
    500
    If you look up the codes on the link posted by eboggs, you'll see that the cats are the first thing that are tested. That is because most of the time those are what fails when these codes are shown. Especially when shown in conjunction with each other.

  8. #8
    run it 'til it breaks. mrr23's Avatar

    Join Date
    Jun 2004
    Location
    orlando, fl
    Posts
    268
    vCash
    500
    all three times i got those codes. i went to the dealer and they replaced the cats. code gone . it's the cats. free replacement 8 years or 80k miles.
    the wife's car 11.397 @ 120.96
    99 formula

    mine 11.189 @ 128.24
    00 formula

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •